When Upgrading to Vizit v1.6, the Search Integration web part does not show up in the web part gallery

When upgrading to Vizit v1.6 from any previous versions, the Search Integration web part feature files are installed but the feature is not installed into SharePoint's feature store, nor is it activated on any site collection.  There are two ways to work around this issue:

  • Retract and reinstall
    1. Retract Vizit v1.6 by re-running the installer and selecting the check box to retract
    2. Re-run the installer again and select the site collections to which you would like the features installed
    3. This new installation will have the web part properly installed
  • Install the web part feature manually
    1. Start a command prompt (Start -> Run -> type 'cmd' in the box and click 'OK')
    2. Change to the BIN directory of your SharePoint 12-hive (normally, C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\BIN)
    3. Run the stsadm command to install the feature
      • stsadm -o installfeature -name VizitSearchIntegration
    4. For this last step you can do one of two things:
      1. Activate the Vizit Search Integration feature from the command line by running the stsadm command for each of the URLs of the site collections where you would like to use the Search Integration web part
      2. Use the web interface on each site collection to activate the feature
        • Site Actions -> Site Settings -> Site Collection Features -> Click the 'Activate' button next to the "Vizit Search Integration" feature listing
    The Vizit Search Integration web part should now show up normally in the web part gallery for selection on the edit page of your search results page.
Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk